Конвертация PHPBB 3 в PHPBB 3.1

Здесь можно обсудить всё, что не связано с тематикой сайта
Закрыто
Ашот Петросян
Репутация: 0
Сообщения: 7
Зарегистрирован: 13 янв 2017, 16:19
  •    

#1 Сообщение Ашот Петросян » 13 янв 2017, 16:23

Перед принятием решения обязательно прочтите Мини [FAQ] по phpBB 3.1.x

Проверить свой сервер на соответствие: phpBB 3.1.x - системные требования.
Сделать бэкап ВСЕГО - и файлов, и базы данных, чтобы потом не было мучительно больно за бесцельно прожитые годы.
Переключить всех пользователей, включая себя, на стиль prosilver (phpBB 3.1.х должен делать это сам, но всё равно не повредит).
Удалить AutoMOD, если он был установлен, а также все "неродные" модули администраторского, модераторского, личного разделов, если таковые были установлены вместе с какими-либо модами. Удалить все "неродные" таблицы, "неродные" колонки из стандартных таблиц, права доступа если таковые были установлены вместе с какими-либо модами (кроме тех, для которых есть портированные расширения). Если это затруднительно сделать вручную, воспользуйтесь инструментом Support ToolKit (STK).
Удалить файлы phpBB 3.0, КРОМЕ:
config.php
папки /images
папки /files
папки /store
Скопировать все файлы phpBB 3.1 в папку, где находится phpBB 3.0 (кроме config.php)
Убедиться в наличии прав доступа к папкам store/, cache/, files/ и images/avatars/upload/ - 777, к файлу config.php - не ниже 666, и выставить таковые при необходимости.
Ввести в адресной строке и запустить /install/database_update.php (после имени домена и пути к форумам).
Удалить (или переименовать) папку /install, изменить права доступа к файлу config.php на 644.
Готово!


Замечание №1: все моды на новой конференции будут потеряны.
Замечание №2: стили для phpBB 3.0 несовместимы со стилями для phpBB 3.1. Если используется уникальный дизайн, его придется обновить или переписать для соответствия phpBB 3.1, иначе он будет потерян.


Перед обновлением обязательно сделать резервные копии всех файлов и базы данных.

за исключением: для обновления базы данных необходимо запустить в браузере /install, затем следовать инструкциям.

Работоспособность расширений от phpBB 3.1 не гарантирована. Более того, часть расширений (например, использующих систему уведомлений) гарантированно несовместима.

Минимальные системные требования для версии PHP повышены - не ниже PHP 5.4.0 (для phpBB 3.1 - 5.3.3).

Закрыто